Blog Azeroth

A forum for World of Warcraft Bloggers
It is currently Thu Nov 27, 2014 4:20 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Wordpress RSS Issues?
PostPosted: Mon Mar 31, 2008 1:49 pm 
Offline

Joined: Thu Mar 20, 2008 2:57 pm
Posts: 12
Location: Scarlet Monastery
Okay, looks like poor Phae's server has calmed down, I'll repost this. (It got eated before.)

My shift over to my new host went well, with one notable exception.

I've had readers mention that my feed links don't work.

Luckily, I have awesome readers, and there's been a lot of good advice for workarounds on it, I just don't know what's causing the problem.

See http://egotisticalpriest.com/?p=157 for more information.

The links are in the footer of the page - if you mouse over them, you can see the missing colon in the link.

That colon is THERE in the code. I've actually hard-coded it, to make 100% sure that it is there, and it was still missing from the mouseover. My OLD blog had the same mouseover issue (before the person holding the account dropped it, so it can't be tested at the moment)

Now, I've actually clicked on the link and followed it all the way through to adding it to my google feed reader, and had no problems. A lot of my readers did have a problem, though, so I can't just tra la la, pretend it didn't happen.

Has anyone else seen or heard of this issue? Why would the colon be stripped out of the feed link?

My bet would be that it's browser related - that colon was THERE in the code.

So...yes. Help?


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Mon Mar 31, 2008 6:15 pm 
Offline
User avatar

Joined: Tue Jan 29, 2008 6:40 am
Posts: 28
Ego, I believe the feed: scheme isn't supposed to have two slashes after it which makes the links invalid. Also feed: isn't a standard so many browsers aren't going to natively support it. Currently both those links work in Firefox but they do not work in Internet Explorer.

To have it work in more browsers change the links and remove the feed: so they read

Code:
http://egotisticalpriest.com/?feed=rss2
http://egotisticalpriest.com/?feed=comments-rss2


Using the following tags should do that.

Code:
<?php bloginfo('rss2_url'); ?>
<?php bloginfo('comments_rss2_url'); ?>


But if you are trying to automatically launch someones feedreader you still may need the feed:. If you want to make that work, post up the code that generates it and we can take a look.

_________________
http://flux.io/


Top
 WWW Profile Send private message  
 
 Post subject:
PostPosted: Tue Apr 01, 2008 1:58 pm 
Offline

Joined: Thu Mar 20, 2008 2:57 pm
Posts: 12
Location: Scarlet Monastery
Thank you, Aos! That seems to have done the trick.

I'm not worried about automatically launching a feed reader - I just want them to be able to add it to a reader without issue.

I'll put a post up to see if the people having the issue still encounter it.

Very much appreciated!


Top
 WWW Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
mergenine: WoW Alliance BB3
World of Warcraft ® ©2004-2007 Blizzard Entertainment, Inc. All rights reserved.